After monitoring post-fix, we're now considering the issue as resolved. We again apologize for any inconvenience.
Posted May 31, 2021 - 23:29 UTC
Update
A fix has been released and we're actively monitoring the situation. We apologize for any inconvenience.
Posted May 31, 2021 - 21:56 UTC
Monitoring
We’ve identified the root cause to be from a rare scenario in which a high volume of longer running API requests cause a deadlock of new database connections. When this happens, some API requests fail as attempts to fetch a new database connection result in a connection timeout.
A fix is currently being worked on and it will be rolled out in the next couple of hours.
Posted May 31, 2021 - 19:52 UTC
Identified
We've identified the issue as being caused by a network connection drop and are investigating the root cause.
Posted May 31, 2021 - 18:10 UTC
Investigating
We're currently experiencing an outage with some requests to our V4 API and are investigating the issue. We apologize for any inconvenience.